#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\d\.\s)(?:(?!\s-\s|\d\.\s).)+"
Local $sString = " 3. product - sub product. The regex gives me the product (first part). However, there are some product which does not have sub product. For example. 6. ComprehensiveBolt. The regex 3. product - sub product" & @CRLF & _
"6. ComprehensiveBolt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")