re = /(?<=\d\.\s)(?:(?!\s-\s|\d\.\s).)+/m
str = ' 3. product - sub product. The regex gives me the product (first part). However, there are some product which does not have sub product. For example. 6. ComprehensiveBolt. The regex 3. product - sub product
6. ComprehensiveBolt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end