use strict;
my $str = ' 3. product - sub product. The regex gives me the product (first part). However, there are some product which does not have sub product. For example. 6. ComprehensiveBolt. The regex 3. product - sub product
6. ComprehensiveBolt';
my $regex = qr/(?<=\d\.\s)(?:(?!\s-\s|\d\.\s).)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}