using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?![^\(]*\))(?![^""']*[""'](?:[^""']*[""'][^""']*[""'])*[^""']*$)";
string input = @"5,(5,5),C'A,B','A,B',',B','A,',""A,B"",C""A,B"" ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}