re = /,(?![^\(]*\))(?![^"']*["'](?:[^"']*["'][^"']*["'])*[^"']*$)/
str = '5,(5,5),C\'A,B\',\'A,B\',\',B\',\'A,\',"A,B",C"A,B" '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end