$re = '/,(?![^\(]*\))(?![^"\']*["\'](?:[^"\']*["\'][^"\']*["\'])*[^"\']*$)/';
$str = '5,(5,5),C\'A,B\',\'A,B\',\',B\',\'A,\',"A,B",C"A,B" ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);