using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":([0-9]+\s+)(.*)$";
string input = @"2018-09-08 10:34:49 10.0 MiB path/of/a/directory
2018-09-08 10:34:49 10.0 MiB path/of/a/directory";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}