// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):([0-9]+\s+)(.*)$").unwrap();
let string = "2018-09-08 10:34:49 10.0 MiB path/of/a/directory
2018-09-08 10:34:49 10.0 MiB path/of/a/directory";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}