$re = '/:([0-9]+\s+)(.*)$/m';
$str = '2018-09-08 10:34:49 10.0 MiB path/of/a/directory
2018-09-08 10:34:49 10.0 MiB path/of/a/directory';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);