using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'[^']*'|\{[^\}]*\}|\S+";
string input = @"insert 'hello world' into {This is a test}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}