package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`'[^']*'|\{[^\}]*\}|\S+`)
var str = `insert 'hello world' into {This is a test}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}