re = /'[^']*'|\{[^\}]*\}|\S+/
str = 'insert \'hello world\' into {This is a test}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end