$re = '/<([a-z]+)((?:[^<]|<%)*)(style)="([^"]*)"([^<]*)>/i';
$str = '<a href="<%= url %>" style="color:#000">Link</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);