re = /<([a-z]+)((?:[^<]|<%)*)(style)="([^"]*)"([^<]*)>/i
str = '<a href="<%= url %>" style="color:#000">Link</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end