using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http:\/\/cs[0-9]+\.[A-z0-9]+\.me[\/]?[^.]*$";
string input = @"http://cs0.abc.menome:)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}