package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^http:\/\/cs[0-9]+\.[A-z0-9]+\.me[\/]?[^.]*$`)
var str = `http://cs0.abc.menome:)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}