re = /^http:\/\/cs[0-9]+\.[A-z0-9]+\.me[\/]?[^.]*$/
str = 'http://cs0.abc.menome:)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end