import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\(868\\)\\ \\d{3}\\ \\d{4})|(^868\\d{7})|(^868\\-\\d{3}\\-\\d{4})|(^868\\ \\d{3}\\-\\d{4})";
final String string = "8680000000\n"
+ "(868) 000 0000\n"
+ "868-000-0000\n"
+ "868 000-0000\n"
+ "8880000000\n"
+ "767-000-0000\n"
+ "868-0000000\n"
+ "(868)0000000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}