const regex = /(^\(868\)\ \d{3}\ \d{4})|(^868\d{7})|(^868\-\d{3}\-\d{4})|(^868\ \d{3}\-\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\(868\\)\\ \\d{3}\\ \\d{4})|(^868\\d{7})|(^868\\-\\d{3}\\-\\d{4})|(^868\\ \\d{3}\\-\\d{4})', 'gm')
const str = `8680000000
(868) 000 0000
868-000-0000
868 000-0000
8880000000
767-000-0000
868-0000000
(868)0000000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}