re = /(^\(868\)\ \d{3}\ \d{4})|(^868\d{7})|(^868\-\d{3}\-\d{4})|(^868\ \d{3}\-\d{4})/m
str = '8680000000
(868) 000 0000
868-000-0000
868 000-0000
8880000000
767-000-0000
868-0000000
(868)0000000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end