const regex = /(^|(>[^\<]*)|(^[^\<]*))(\{\{[^\{\}]*\}\})/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|(>[^\\<]*)|(^[^\\<]*))(\\{\\{[^\\{\\}]*\\}\\})', 'igm')
const str = `<div id="test" class="test1">{{message.id}} + a fee</div>
test {{message.body}}`;
const subst = `<span ng-bind="$4"></span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);