import re
regex = re.compile(r"(^|(>[^\<]*)|(^[^\<]*))(\{\{[^\{\}]*\}\})", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<div id=\"test\" class=\"test1\">{{message.id}} + a fee</div>\n"
"test {{message.body}}")
subst = "<span ng-bind=\"$4\"></span>"
result = regex.sub(subst, test_str)
if result:
print(result)