// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(^|(>[^\<]*)|(^[^\<]*))(\{\{[^\{\}]*\}\})").unwrap();
let string = "<div id=\"test\" class=\"test1\">{{message.id}} + a fee</div>
test {{message.body}}";
let substitution = "<span ng-bind=\"$4\"></span>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}