package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\~\![A-Za-z]+\ start(?:(?:(?:\(|,)\ ?[\w]+)*?\))\:\{([\S\s]+?)(?:[^\\]\}\:end)`)
var str = `~!data start(f1, f2, f3):{
abc '\}:end'a
}:end
~!data start(f1, f2, f3):{
abc '\}:end'a
\}:end`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}