$re = '/\~\![A-Za-z]+\ start(?:(?:(?:\(|,)\ ?[\w]+)*?\))\:\{([\S\s]+?)(?:[^\\\\]\}\:end)/m';
$str = '~!data start(f1, f2, f3):{
abc \'\\}:end\'a
}:end
~!data start(f1, f2, f3):{
abc \'\\}:end\'a
\\}:end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);