re = /\~\![A-Za-z]+\ start(?:(?:(?:\(|,)\ ?[\w]+)*?\))\:\{([\S\s]+?)(?:[^\\]\}\:end)/m
str = '~!data start(f1, f2, f3):{
abc \'\\}:end\'a
}:end
~!data start(f1, f2, f3):{
abc \'\\}:end\'a
\\}:end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end