package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(?:,\s*\w+)*\s+(?:and|or)\s+\w+$`)
var str = `red, white and blue
red, white, and blue`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}