re = /^\w+(?:,\s*\w+)*\s+(?:and|or)\s+\w+$/m
str = 'red, white and blue
red, white, and blue'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end