$re = '/^\w+(?:,\s*\w+)*\s+(?:and|or)\s+\w+$/m';
$str = 'red, white and blue
red, white, and blue';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);