package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z0-9*&@]+`)
var str = `abc
123
abc@123
abc@123.com
abc&*@domain.com
1&2&3@abc@ABC@123@123@123@123@123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}