use strict;
my $str = '<a href="http://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="https://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related"></a>
<a href="http://youtu.be/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="www.youtu.be/iwGFalTRHDA"></a>
<a href="youtu.be/iwGFalTRHDA"></a>
<a href="youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/v/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/v/i_GFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related"></a>
<a href="http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA"></a>
<a href="http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail"></a>
<a href="http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ"></a>';
my $regex = qr/<a\s*href="(?:https?:\/\/)?(?:www\.)?youtu(?:\.be|be\.com)\/(?:.*v=|v\/|watch\/|)([-\w]+)[^"]*"[^>]*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}