$re = '/<a\s*href="(?:https?:\/\/)?(?:www\.)?youtu(?:\.be|be\.com)\/(?:.*v=|v\/|watch\/|)([-\w]+)[^"]*"[^>]*>/i';
$str = '<a href="http://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="https://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related"></a>
<a href="http://youtu.be/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="www.youtu.be/iwGFalTRHDA"></a>
<a href="youtu.be/iwGFalTRHDA"></a>
<a href="youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/v/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/v/i_GFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related"></a>
<a href="http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA"></a>
<a href="http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail"></a>
<a href="http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);