import Foundation
let pattern = #"<a\s*href="(?:https?:\/\/)?(?:www\.)?youtu(?:\.be|be\.com)\/(?:.*v=|v\/|watch\/|)([-\w]+)[^"]*"[^>]*>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="https://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA&feature=related"></a>
<a href="http://youtu.be/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/watch?feature=player_embedded&v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/embed/v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?feature=player_embedded&v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="www.youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="www.youtu.be/iwGFalTRHDA"></a>
<a href="youtu.be/iwGFalTRHDA"></a>
<a href="youtube.com/watch?v=iwGFalTRHDA"></a>
<a href="http://www.youtube.com/watch/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/v/iwGFalTRHDA"></a>
<a href="http://www.youtube.com/v/i_GFalTRHDA"></a>
<a href="http://www.youtube.com/watch?v=i-GFalTRHDA&feature=related"></a>
<a href="http://www.youtube.com/attribution_link?u=/watch?v=aGmiw_rrNxk&feature=share&a=9QlmP1yvjcllp0h3l0NwuA"></a>
<a href="http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&u=/watch?v=qYr8opTPSaQ&feature=em-uploademail"></a>
<a href="http://www.youtube.com/attribution_link?a=fF1CWYwxCQ4&feature=em-uploademail&u=/watch?v=qYr8opTPSaQ"></a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)