using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name=""(.+?)""";
string input = @"<outputColumn id=""426"" name=""Net Salary per month € (3rd Applicant)"" description="" lineageId=""426"" precision=""0"" scale=""0"" length=""255"" dataType=""wstr"" codePage=""0"" sortKeyPosition=""0"" comparisonFlags=""0"" specialFlags=""0"" errorOrTruncationOperation=""Conversion"" errorRowDisposition=""FailComponent"" truncationRowDisposition=""FailComponent"" externalMetadataColumnId=""425"" mappedColumnId=""0""/>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}