// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)name="(.+?)""#).unwrap();
let string = "<outputColumn id=\"426\" name=\"Net Salary per month € (3rd Applicant)\" description=\"\" lineageId=\"426\" precision=\"0\" scale=\"0\" length=\"255\" dataType=\"wstr\" codePage=\"0\" sortKeyPosition=\"0\" comparisonFlags=\"0\" specialFlags=\"0\" errorOrTruncationOperation=\"Conversion\" errorRowDisposition=\"FailComponent\" truncationRowDisposition=\"FailComponent\" externalMetadataColumnId=\"425\" mappedColumnId=\"0\"/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}