import re
regex = re.compile(r"name=\"(.+?)\"", flags=re.IGNORECASE | re.MULTILINE)
test_str = "<outputColumn id=\"426\" name=\"Net Salary per month € (3rd Applicant)\" description=\"\" lineageId=\"426\" precision=\"0\" scale=\"0\" length=\"255\" dataType=\"wstr\" codePage=\"0\" sortKeyPosition=\"0\" comparisonFlags=\"0\" specialFlags=\"0\" errorOrTruncationOperation=\"Conversion\" errorRowDisposition=\"FailComponent\" truncationRowDisposition=\"FailComponent\" externalMetadataColumnId=\"425\" mappedColumnId=\"0\"/>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")