import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bDate:\\s\\d{1,2}\\.\\d{1,2}\\.\\d{4}[\\s\\S]*?(?=\\nDate:|$)";
final String string = "Date: 01.02.2015\n"
+ "something\n"
+ "something more\n"
+ "some random more\n"
+ "Date: 02.02.2015\n"
+ "something random\n"
+ "i dont know";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}