$re = '/\bDate:\s\d{1,2}\.\d{1,2}\.\d{4}[\s\S]*?(?=\nDate:|$)/';
$str = 'Date: 01.02.2015
something
something more
some random more
Date: 02.02.2015
something random
i dont know';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);