re = /\bDate:\s\d{1,2}\.\d{1,2}\.\d{4}[\s\S]*?(?=\nDate:|$)/
str = 'Date: 01.02.2015
something
something more
some random more
Date: 02.02.2015
something random
i dont know'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end