import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ATEAM-[0-9]+(?=.*?#finish)";
final String string = "ATEAM-3121 ATEAM-31 123 ATEAM-32 #finish \\n ATEAM-3211 \\n ATEAM-51 ATEAM-52 ATEAM-53 12345677 #finish ATEAM-1000";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}