const regex = /ATEAM-[0-9]+(?=.*?#finish)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ATEAM-[0-9]+(?=.*?#finish)', 'gim')
const str = `ATEAM-3121 ATEAM-31 123 ATEAM-32 #finish \\n ATEAM-3211 \\n ATEAM-51 ATEAM-52 ATEAM-53 12345677 #finish ATEAM-1000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}