re = /ATEAM-[0-9]+(?=.*?#finish)/im
str = 'ATEAM-3121 ATEAM-31 123 ATEAM-32 #finish \\n ATEAM-3211 \\n ATEAM-51 ATEAM-52 ATEAM-53 12345677 #finish ATEAM-1000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end