package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?P<provincia>[a-hj-np-z])(?P<numero>[\d]{1,4})(?P<calle>[a-z]{3})`)
var str = `C1417AUV`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}