re = /(?i)(?P<provincia>[a-hj-np-z])(?P<numero>[\d]{1,4})(?P<calle>[a-z]{3})/
str = 'C1417AUV'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end