$re = '/(?i)(?P<provincia>[a-hj-np-z])(?P<numero>[\d]{1,4})(?P<calle>[a-z]{3})/';
$str = 'C1417AUV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);