#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d*([.,](?=\d{3}))?\d+)+((?!\2)[.,]\d\d)?$"
Local $sString = "wrong" & @CRLF & _
"1,234,56" & @CRLF & _
"1.234.56" & @CRLF & _
"-1993" & @CRLF & _
"918,27.63" & @CRLF & _
"122.42.24" & @CRLF & _
"1,89,2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"intl. format & US national format" & @CRLF & _
"2.56" & @CRLF & _
"14.56" & @CRLF & _
"134.56" & @CRLF & _
"1,234.56" & @CRLF & _
"2,991,234.00" & @CRLF & _
"" & @CRLF & _
"Italian national format with 2 decimals" & @CRLF & _
"9,56" & @CRLF & _
"24,56" & @CRLF & _
"134,56" & @CRLF & _
"721.234,56" & @CRLF & _
"21.234,56" & @CRLF & _
"1.234,56" & @CRLF & _
"9.321.234,56" & @CRLF & _
"69.321.234,56" & @CRLF & _
"269.321.234,56" & @CRLF & _
"1.269.321.234,56" & @CRLF & _
"" & @CRLF & _
"international format for the de_DE locale" & @CRLF & _
"1,56" & @CRLF & _
"14,56" & @CRLF & _
"134,56" & @CRLF & _
"1234,56" & @CRLF & _
"98281234,56" & @CRLF & _
"" & @CRLF & _
"no cents" & @CRLF & _
"1" & @CRLF & _
"14" & @CRLF & _
"134" & @CRLF & _
"1,234" & @CRLF & _
"2,991,234" & @CRLF & _
"9" & @CRLF & _
"24" & @CRLF & _
"134" & @CRLF & _
"1.234" & @CRLF & _
"9.321.234" & @CRLF & _
"1" & @CRLF & _
"14" & @CRLF & _
"134" & @CRLF & _
"1234" & @CRLF & _
"98281234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")