$re = '/^(\d*([.,](?=\d{3}))?\d+)+((?!\2)[.,]\d\d)?$/m';
$str = 'wrong
1,234,56
1.234.56
-1993
918,27.63
122.42.24
1,89,2
intl. format & US national format
2.56
14.56
134.56
1,234.56
2,991,234.00
Italian national format with 2 decimals
9,56
24,56
134,56
721.234,56
21.234,56
1.234,56
9.321.234,56
69.321.234,56
269.321.234,56
1.269.321.234,56
international format for the de_DE locale
1,56
14,56
134,56
1234,56
98281234,56
no cents
1
14
134
1,234
2,991,234
9
24
134
1.234
9.321.234
1
14
134
1234
98281234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);