use strict;
my $str = 'wrong
1,234,56
1.234.56
-1993
918,27.63
122.42.24
1,89,2
intl. format & US national format
2.56
14.56
134.56
1,234.56
2,991,234.00
Italian national format with 2 decimals
9,56
24,56
134,56
721.234,56
21.234,56
1.234,56
9.321.234,56
69.321.234,56
269.321.234,56
1.269.321.234,56
international format for the de_DE locale
1,56
14,56
134,56
1234,56
98281234,56
no cents
1
14
134
1,234
2,991,234
9
24
134
1.234
9.321.234
1
14
134
1234
98281234';
my $regex = qr/^(\d*([.,](?=\d{3}))?\d+)+((?!\2)[.,]\d\d)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}