const regex = /(.+?([A-Z].)\.(?:['")\\\s]?)+?\s?)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?([A-Z].)\\.(?:[\'")\\\\\\s]?)+?\\s?)', 'igm')
const str = `If he's restin', I'll wake him up! (Shouts at the cage.) 'Ello, Mister Polly Parrot! (Owner hits the cage.) There, he moved!!!\\r\\n\\r\\nNorth Korea is accusing the U.S. government of being behind the making of the movie \\"The Interview.\\"\\r\\n\\r\\nAnd, in a dispatch on state media, the totalitarian regime warns the United States that U.S. \\"citadels\\" will be attacked, dwarfing the attack on Sony that led to the cancellation of the film's release.\\r\\n\\r\\nWhile steadfastly denying involvement in the hack, North Korea accused U.S. President Barack Obama of calling for \\"symmetric counteraction.\\"\\r\\n\\r\\n\\"The DPRK has already launched the toughest counteraction. Nothing is more serious miscalculation than guessing that just a single movie production company is the target of this counteraction. Our target is all the citadels of the U.S. imperialists who earned the bitterest grudge of all Koreans,\\" a report on state-run KCNA read."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}