// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?im)(.+?([A-Z].)\.(?:['")\\\s]?)+?\s?)"#).unwrap();
let string = "If he's restin', I'll wake him up! (Shouts at the cage.) 'Ello, Mister Polly Parrot! (Owner hits the cage.) There, he moved!!!\\r\\n\\r\\nNorth Korea is accusing the U.S. government of being behind the making of the movie \\\"The Interview.\\\"\\r\\n\\r\\nAnd, in a dispatch on state media, the totalitarian regime warns the United States that U.S. \\\"citadels\\\" will be attacked, dwarfing the attack on Sony that led to the cancellation of the film's release.\\r\\n\\r\\nWhile steadfastly denying involvement in the hack, North Korea accused U.S. President Barack Obama of calling for \\\"symmetric counteraction.\\\"\\r\\n\\r\\n\\\"The DPRK has already launched the toughest counteraction. Nothing is more serious miscalculation than guessing that just a single movie production company is the target of this counteraction. Our target is all the citadels of the U.S. imperialists who earned the bitterest grudge of all Koreans,\\\" a report on state-run KCNA read.\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}